Unable to access Acronis Portal

Incident
June 20, 2:52pm BST

Unable to access Acronis Portal

Status: Closed
Start: June 20, 11:32am BST
End: June 20, 2:52pm BST
Duration: 3 hours 19 minutes
Affected Components:
Acronis Acronis Cyber Cloud Acronis Backup Acronis Files Cloud
Update

June 20, 11:32am BST

June 20, 11:32am BST

Good Morning,

We have received multiple reports of users being unable to connect and login to eu-cloud.acronis.com.

When navigating to this page, users are receiving 'This site cannot be reached'.

We are currently getting in touch with our contacts at Acronis for further information, and we will aim to provide a further update as soon as possible.

Resolved

June 20, 2:52pm BST

June 20, 2:52pm BST

Good Afternoon,

We are pleased to confirm that users are now able to connect to https://eu-cloud.acronis.com again.

After querying this with our contacts at Acronis, this was caused due to a temporary outage of their Data Centre.

We apologise for the inconvenience this may have caused.