Microsoft 365 Order Issues

Incident
June 21, 9:13am BST

Microsoft 365 Order Issues

Status: Closed
Start: June 20, 3:08pm BST
End: June 21, 9:13am BST
Duration: 18 hours 4 minutes
Affected Components:
Microsoft Exchange Online Dynamics Power BI
Update

June 20, 3:08pm BST

June 20, 3:08pm BST

Good Afternoon,

We are currently experiencing issues when processing Microsoft 365 orders, due to issues currently regarding the Microsoft Partner Center.

As soon as we have further information regarding this, we will update this status accordingly.

Resolved

June 21, 9:13am BST

June 21, 9:13am BST

Good morning, 

After monitoring this issue after it's resolution we are now happy to close this.

Any orders placed that were delayed or failed have now been completed.

If you placed an order and did not get a confirmation email, please check your customer in the cloud.market via Manage services to see if the order was placed. If not you are free to place it as usual.