Microsoft 365 Mailflow Delay

Incident
June 22, 8:42am BST

Microsoft 365 Mailflow Delay

Status: Closed
Start: June 21, 11:21am BST
End: June 22, 8:42am BST
Duration: 21 hours 20 minutes
Affected Components:
Microsoft Exchange Online Dynamics Power BI
Update

June 21, 11:21am BST

June 21, 11:21am BST

Microsoft are currently seeing a degradation of their Exchange platform. This is currently impacting mailflow and causing delays.

Microsoft reference for this case: EX394347

Should you identify that your customer is experiencing this issue, please get in touch with our technical support team. We are raising these cases to Microsoft for further investigation.

We will keep you advised once a resolution has been found.


Update

June 21, 11:44am BST

June 21, 11:44am BST

We can confirm that Microsoft is seeing a global issue with their Exchange servers. This is impacting mailflow and causing delays.

This is a service outage is being worked on by the Microsoft engineering team as a matter of priority.

Microsoft will provide updates on the Service Health page under the following reference: EX394347

We will keep you notified of any further updates.

Update

June 21, 2:29pm BST

June 21, 2:29pm BST

This is an update in regards to M365 Mailflow delays.

Microsoft have identified that their traffic management infrastructure was not working as expected. They have successfully rerouted traffic, and they're seeing an improvement in service availability.

We will continue to monitor until a resolution is found.

Resolved

June 22, 8:42am BST

June 22, 8:42am BST

Microsoft have confirmed that a restart of their infrastructure resources has resolved the issue with mail flow.

This has also resolved minor issues that were impacting Exchange changes such as mail forwarding and alias changes.

We are resolving the parent record on our side for this issue. Please reach out to our technical team if you encounter any further problems