Manage Users section showing no users

Incident
June 23, 12:30pm BST

Manage Users section showing no users

Status: Closed
Start: June 22, 11:37am BST
End: June 23, 12:30pm BST
Duration: 1 day 52 minutes
Affected Components:
Cloud Cloud.Market
Update

June 22, 11:37am BST

June 22, 11:37am BST

Good Morning, 

We have identified an issue with the Manage Users page not loading any users.

Our Development team are working on this currently, however we do not have an ETA of when this will be resolved.

Engineers and Customer admins cannot be edited, however they remain operational as normal.

We apologise for any inconvenience caused, and your patience is appreciated at this time.

Resolved

June 23, 12:30pm BST

June 23, 12:30pm BST

We have now released a fix for this, both Customer admins and Engineers are now loaded as expected and can be created/modified as required.