Exchange 2016 OWA failing to load

Incident
June 27, 9:00am BST

Exchange 2016 OWA failing to load

Status: Closed
Start: June 25, 7:04pm BST
End: June 27, 9:00am BST
Duration: 1 day 13 hours 55 minutes
Affected Components:
Exchange 2016
Update

June 25, 7:04pm BST

June 25, 7:04pm BST

We can confirm that at this time, our Exchange 2016 Outlook-for-Web portal (webmail.giacomcp.com) is failing to resolve to the mailbox after login.

An error is received that prevents propagation of the Mailbox.

Our Exchange engineers have been notified and we are investigating. The status page will be kept updated with our progress.

Update

June 25, 7:33pm BST

June 25, 7:33pm BST

Our Exchange team have advised that a solution this evening will unfortunately be unlikely.

They have advised that there will be an update tomorrow on this case.

We will continue to monitor and keep the status page up to date on our progress.

Update

June 26, 12:27pm BST

June 26, 12:27pm BST

Our Exchange team have investigated the issue this morning and have applied a fix.

We are still testing the results of this, but we are hopeful that this should resolve the issue as the day progresses.

We will continue to monitor and update accordingly

Update

June 26, 2:08pm BST

June 26, 2:08pm BST

Our Exchange team have conducted further testing after the fix was applied.

From our investigations, the issue appears resolved and behaviour has returned to normal.

If you should encounter the issue, please contact our technical support team.

Resolved

June 27, 9:00am BST

June 27, 9:00am BST

Following on from further testing and the lack of further reports we are not confident the issue is fully resolved.

If any Exchange 2016 users still see an issue logging into webmail.giacomcp.com please raise a ticket for us to investigate directly.