Hosted Exchange issues

Incident
November 03, 12:11pm GMT

Hosted Exchange issues

Status: Closed
Start: November 03, 9:40am GMT
End: November 03, 12:11pm GMT
Duration: 2 hours 30 minutes
Affected Components:
Hosted Exchange Exchange 2010 Exchange 2013 Exchange 2016
Update

November 03, 9:40am GMT

November 03, 9:40am GMT

Good morning,

We've become aware of a increased number of calls regarding our Hosted Exchange service and Password prompts on Outlook and Mobile.

We are investigating as we speak to confirm if this is a fault with our platform.

There is some indication that OWA should work from some of the customers we've spoken to so far.

We should have fault confirmation shortly.

We apologise for any inconvenience caused.

Update

November 03, 9:57am GMT

November 03, 9:57am GMT

Good morning,

We've performed some work to attempt to alleviate this issue, however we're currently investigating other possible causes. 

In some cases OWA does not appear to be proving to be a resolution.

If you've not raised a ticket already, please can you provide some example affected users and when the issue started for them if possible, when raising your case.

If you already have a case, and that information was not provided, please can you update it with that.

Kind Regards,

Giacom Service Desk

Resolved

November 03, 12:11pm GMT

November 03, 12:11pm GMT

Good afternoon,

We're confident the issue has now been resolved.

There was performance issues with one of our servers that has been removed from our pool.

If you are still having issues please let us know.


Kind regards
Giacom - Service Desk