Outbound emails delayed on Outbound Hosted Exchange emails

Incident
December 02, 8:48am GMT

Outbound emails delayed on Outbound Hosted Exchange emails

Status: Closed
Start: December 01, 2:09pm GMT
End: December 02, 8:48am GMT
Duration: 18 hours 38 minutes
Affected Components:
Hosted Exchange Exchange 2010 Exchange 2013 Exchange 2016
Update

December 01, 2:09pm GMT

December 01, 2:09pm GMT

We are currently aware of a delay on outbound emails leaving the Hosted Exchange platform.

At this time our engineers are investigating to confirm the full scope and to resolve the issue.

If you encounter this issue, please contact our technical support team.

We will keep you advised of our progress.

Update

December 01, 4:14pm GMT

December 01, 4:14pm GMT

Our engineers have isolated the cause of the issue and we are currently working towards resolving the problem.

 

If you are still experiencing this issue, please provide the headers of received delayed emails to our technical support team.

 

We will use this information to further investigate the problem.

Resolved

December 02, 8:48am GMT

December 02, 8:48am GMT

Good morning,

Our teams resolved this issue yesterday around 5PM, mail delays should no longer be occuring.

If you are still having this issue, please ensure the emails were sent after 5pm yesterday. If not, please get them to test again.

We identified the issue to be one of the outbound servers in our cluster, which has been removed for further investigation and repair.

Our apologies for any inconvenience caused.

Kind Regards,

Giacom - Service Desk