Hosted Exchange Maintenance

Scheduled
September 20, 10:40am BST

Hosted Exchange Maintenance

Status: Closed
Start: September 14, 7:00pm BST
End: September 20, 10:40am BST
Duration: 5 days 15 hours 40 minutes
Affected Components:
Hosted Exchange Email Security Exchange 2010 Exchange 2013 Exchange 2016
Update

September 14, 7:00pm BST

September 14, 7:00pm BST

We are scheduling some Maintenance on one of our Email Security servers for Wednesday 14th September, which will occur between 19:00 and 22:00hrs. 

Whilst this maintenance is expected to cause minimal to no downtime, we anticipate that this may cause delays in mailflow.

However, this maintenance will heavily affect the administration side of things on our Cloud Market portal. This means that the following will be affected:

Archive access
Redelivery of emails
Adding Mailboxes
Adding Aliases
Adding Distribution Groups
Editing Distribution Groups
Editing Customer settings

Your mailboxes should still operate as normal, and changing mailbox passwords too, as these are on separate servers.

We apologise for any disruption this may cause, however the maintenance we are doing will ensure fewer issues across our entire Hosted Exchange platform.

Resolved

September 20, 10:40am BST

September 20, 10:40am BST

Closed