Microsoft 365 order placement impact

Informational
October 13, 10:28am BST

Microsoft 365 order placement impact

Status: Closed
Date: October 13, 9:40am BST
End: October 13, 10:28am BST
Duration: 47 minutes
Affected Components:
Microsoft Exchange Online Dynamics Power BI
Update

October 13, 9:40am BST

October 13, 9:40am BST

We are receiving reports that some users are unable to place Microsoft 365 orders. The behaviour being seen is either that of a generic contact support error, or the 'Getting Listings' page times out before resolving to the product list.

Our team is currently investigating the full impact of this issue. We will keep you advised of our progress.

Resolved

October 13, 10:28am BST

October 13, 10:28am BST

Our Development team were able to identify and resolve the issue that was causing the order time outs.

Behaviour is now back to normal. However should you encounter any further issues please contact our Technical Support team.