Unable to view Invoices

Incident
November 30, 1:42pm GMT

Unable to view Invoices

Status: Closed
Start: November 30, 8:53am GMT
End: November 30, 1:42pm GMT
Duration: 4 hours 48 minutes
Affected Components:
Cloud Cloud.Market Billing API
Update

November 30, 8:53am GMT

November 30, 8:53am GMT

We are currently aware of an issue that is preventing invoices to be viewable in the Billing section of Cloud Market.

Our engineers are investigating as a matter of priority and we will update you upon resolution. 

Update

November 30, 11:05am GMT

November 30, 11:05am GMT

We will be releasing a fix around 12:00 today that should resolve this issue.

After release we will conduct further testing to ensure this is the case.

We will keep you advised of our progress.

Resolved

November 30, 1:42pm GMT

November 30, 1:42pm GMT

Our development team have resolved the issue that was preventing Invoices from being viewed/

Invoices are now visible again in the Cloud Market.

Should you encounter any technical issues please get in touch with our technical support team for further assistance.