Giacom - Phone System Down

Incident
March 01, 9:28am GMT

Giacom - Phone System Down

Status: Closed
Start: March 01, 9:25am GMT
End: March 01, 9:28am GMT
Duration: 3 minutes
Affected Components:
Giacom
Update

March 01, 9:25am GMT

March 01, 9:25am GMT

Good morning,

Unfortunately the service that provides our phone system is currently down and we are unable to receive any incoming calls.

Our provider is working on this as we speak. You can still contact us via LiveChat, Ticket or Email.

We apologise for the inconvenience caused.

Kind Regards,

Giacom

Resolved

March 01, 9:28am GMT

March 01, 9:28am GMT

Good morning,

The systems are now up and running again.


We apologise for any inconvenience caused.

Kind Regards,

Giacom