EX522020 - Users may be unable to access their Exchange Online mailbox or send/receive messages

Incident
March 02, 9:35am GMT

EX522020 - Users may be unable to access their Exchange Online mailbox or send/receive messages

Status: Closed
Start: March 01, 5:58pm GMT
End: March 02, 9:35am GMT
Duration: 15 hours 36 minutes
Affected Components:
Microsoft Exchange Online Dynamics Power BI
Update

March 01, 5:58pm GMT

March 01, 5:58pm GMT

Microsoft Reference Number: EX522020

User impact: Users may be unable to access their Exchange Online mailboxes or send and receive email messages. More info: Users may receive an error message including: “550 5.4.1 Recipient address rejected: Access denied” when attempting to send or receive messages. Current status: We’ve identified a potential Directory Based Edge Blocking (DBEB) issue that may be contributing to impact. We’re investigating this alongside our existing diagnostic data to determine our next steps. Scope of impact: Impact is specific to users who are served through the affected infrastructure in North America, Europe, and the United Kingdom.


Resolved

March 02, 9:35am GMT

March 02, 9:35am GMT

Good Morning,

Microsoft have confirmed that the issue is now resolved.

Preliminary root cause: A portion of Exchange Online Protection (EOP) infrastructure wasn’t operating as expected due to a potential misconfiguration, resulting in the impact.

If you continue to have issues sending/receiving mail, please reach out to the Technical Support Team to investigate further.