Exclaimer Outlook Add-in failing to fetch signatures

Incident
March 08, 5:51pm GMT

Exclaimer Outlook Add-in failing to fetch signatures

Status: Closed
Start: March 08, 11:40am GMT
End: March 08, 5:51pm GMT
Duration: 6 hours 11 minutes
Affected Components:
Exclaimer 365 Email Signatures
Update

March 08, 11:40am GMT

March 08, 11:40am GMT

We have received multiple reports of users receiving the following error when using the Exclaimer Outlook Add-in:

'Download signature list failed - Failed to fetch'

We are investigating this further, and we will provide a further update once we know more.

This does not seem to be affecting server side signatures.

Update

March 08, 12:08pm GMT

March 08, 12:08pm GMT

Exclaimer have confirmed that this is a known issue. They are investigating this further internally, and we will aim to provide a further update as soon as possible.

The latest update from Exclaimer is as follows:

Issue: Our metrics provider Datadog is currently unable to provide us with accurate metrics and health data. This is impacting our ability to scale the service automatically in line with load, as well as proactively identify performance problems. We have manually scaled key systems in order to ensure continued levels of service. 

Symptoms: Some services may be reporting errors or delayed response

Monitoring

March 08, 3:29pm GMT

March 08, 3:29pm GMT

We have had confirmation from Exclaimer that all systems are now functioning again as normal, and you should no longer encounter any performance issues when using the service.

We will be monitoring this case for the time being, and we will provide an update if anything changes.

Resolved

March 08, 5:51pm GMT

March 08, 5:51pm GMT

Good Afternoon,

After further monitoring, we are confident that the issue is now resolved.

If you continue to experience issues, please reach out to the Technical Support Team to investigate further.