Hosted Exchange 2010 - Unable to access via Outlook or OWA

Incident
March 30, 12:14pm BST

Hosted Exchange 2010 - Unable to access via Outlook or OWA

Status: Closed
Start: March 20, 3:04pm GMT
End: March 30, 12:14pm BST
Duration: 9 days 20 hours 9 minutes
Affected Components:
Hosted Exchange Exchange 2010
Update

March 20, 3:04pm GMT

March 20, 3:04pm GMT

Good Afternoon,

We are aware of an issue which is preventing users on certain ISPs, from being able to access their mailbox via Outlook and Webmail (OWA).

Our Infrastructure Team are aware of this, and are investigating further. We will aim to provide a further update regarding this as soon as possible.

As a workaround in the meantime, please whitelist the following URL on your router:

messageexchange.com


Update

March 21, 9:56am GMT

March 21, 9:56am GMT

Good Morning,

Our Infrastructure Team have contacted the currently known affected ISPs to assist in removing messageexchange.com from their blocklists, and we will aim to provide a further update as soon as possible.

To help expedite the process, please could affected users report as a false positive case to your ISPs directly.

Update

March 23, 1:57pm GMT

March 23, 1:57pm GMT

Good Afternoon,

We are still awaiting further feedback from the affected ISPs regarding the delisting of messageexchange.com, and we will aim to provide a further update as soon as possible.

A workaround for this for the time being would be to whitelist messageexchange.com on your router/content filtering service your ISP provides.

Also, if you are able to assist by raising as a false positive to the ISP directly, this would help expedite the delisting process.


Update

March 28, 10:21am BST

March 28, 10:21am BST

Good Morning,

We are still awaiting further feedback from the ISPs regarding our delisting, and our Infrastructure Team are continuing to chase up with them to help get this resolved as soon as possible.

We will aim to provide a further update as soon as possible.

Monitoring

March 29, 10:12am BST

March 29, 10:12am BST

Good Morning,

We have had confirmation from one of the ISPs that messageexchange.com has now been delisted and marked as clean.

Upon doing checks on our side, it does no longer look to be on blocklists. If you have been affected, please can you retry accessing Outlook and OWA.

If the issue persists, please let us know along with the ISP being used, so we can investigate further.

Resolved

March 30, 12:14pm BST

March 30, 12:14pm BST

Good Afternoon,

After further monitoring, we are confident the issue is now resolved.

If you are experiencing any issues, please reach out to the Technical Support Team to investigate further.