Condition Access flagging IP address as wrong Geolocation

Incident
March 24, 8:22am GMT

Condition Access flagging IP address as wrong Geolocation

Status: Closed
Start: March 23, 1:35pm GMT
End: March 24, 8:22am GMT
Duration: 18 hours 46 minutes
Affected Components:
Microsoft Azure Exchange Online Dynamics Power BI
Update

March 23, 1:35pm GMT

March 23, 1:35pm GMT

We can confirm that at this time, Microsoft are reporting an issue with conditional access falsely flagging IP addresses as being from the incorrect country.

This is preventing users from accessing the platform where conditional access is set. It does not seem to be platform wide but we are seeing reports of the behaviour.

Microsoft have advised that this was due to an infrastructure update. They are in the process of fixing the issue as a matter of urgency.

Their current progress can be tracked in the Health centre of M365 under incident number MO531859.

We will keep you advised of all further updates.

Update

March 23, 4:00pm GMT

March 23, 4:00pm GMT

Microsoft have confirmed that the fix they are implementing is progressing.

Their latest update has confirmed that 70% of affected users have had the fix applied. These users should be seeing a significantly less impact or are back to expected behaviour.

We will continue to keep you advised as Microsoft continue to work through the issue.

Resolved

March 24, 8:22am GMT

March 24, 8:22am GMT

We can confirm that Microsoft has confirmed completion of their troubleshooting efforts and have fully resolved the issue.

Conditional Access should now have returned to expected behaviour.

We will now close this case as resolved, however should you identify that the issue is ongoing for your customer, please contact our technical support team who will be able to provide further assistance.