Exclaimer Cloud Portal - Service Maintenance

Scheduled
October 02, 1:00am BST

Exclaimer Cloud Portal - Service Maintenance

Status: Closed
Start: October 01, 1:00am BST
End: October 02, 1:00am BST
Duration: 1 day
Affected Components:
Exclaimer 365 Email Signatures
Update

October 01, 1:00am BST

October 01, 1:00am BST

Exclaimer's engineers will be performing maintenance to continue to improve the service offering.

The Exclaimer Cloud Portal may be unavailable during the update window however your emails will continue to flow and be imprinted as normal.


Resolved

October 02, 1:00am BST

October 02, 1:00am BST

The Exclaimer team have completed their maintenance without issue.

If you are experiencing any problems accessing the portal, please get in touch with the Service Desk to investigate further.