M365 Order delays

Incident
February 20, 3:24pm GMT

M365 Order delays

Status: Closed
Start: February 19, 10:32am GMT
End: February 20, 8:48am GMT
Duration: 22 hours 16 minutes
Affected Components:
Modern Workplace Microsoft Microsoft 365
Update

February 19, 10:32am GMT

February 19, 10:32am GMT

Good Morning,

We're aware of an issue where some Microsoft 365 orders are showing as completed in cloud market but aren't currently showing in the M365 admin center. 

From our internal investigation this looks to be a provisioning issue on the Microsoft end, the licences are showing in the partner center but in a 'pending' state.

Our team are actively monitoring and will aim to update this status as we see progress towards a resolution

We apologise for the inconvenience caused.

Kind Regards,

Giacom - Service Desk

Update

February 19, 10:50am GMT

February 19, 10:50am GMT

Good Morning,

Microsoft have now confirmed that this is a known issue on their end providing the following statement:

New-commerce seat-based orders are getting stuck in pending state and not getting fulfilled, this affects both new Orders and Seat Upgrades. We're working to resolve these issues at the earliest.

We will continue to monitor this and keep you all informed

Kind Regards,

Giacom - Service Desk

Update

February 19, 4:04pm GMT

February 19, 4:04pm GMT

Good Afternoon,

Microsoft are still investigating this internally and a fix is aimed to be provided and all remaining orders to be out of a pending state shortly.

Once we have confirmation of a full resolution we will advise further.


Kind Regards,

Giacom - Service Desk

Update

February 19, 4:27pm GMT

February 19, 4:27pm GMT

Good Afternoon,

We have now been informed of a fix from Microsoft in regards to the ongoing issue, please see the latest update from them below:


"Issue is mitigated for new orders. Orders placed earlier are being processed and eta for completion before 6:00 PM UTC"


Kind Regards,

Giacom - Service Desk

Resolved

February 20, 8:48am GMT

February 20, 8:48am GMT

Good Morning,


We have now received an update from Microsoft stating that all impacted orders have now been processed, this has also been checked internally by Giacom to ensure we are seeing this behaviour reflecting.


We will now go ahead and mark this incident as resolved, if you do continue to see any issues with orders not populating within the M365 Admin center even though the orders are complete on cloud market, please give us a call on 03304333888 > option 4 > option 4 > option 1 or alternatively raise a ticket with the technical support team.

Any outstanding orders which are in a failed state are currently being investigated internally to be pushed through.

Kind Regards,

Giacom - Service Desk

Root Cause

February 20, 9:52am GMT

February 20, 9:52am GMT

Good Morning,

We have now reran all outstanding orders and these have been confirmed as complete.

if you do continue to see any issues with orders not populating within the M365 Admin center even though the orders are complete on cloud market, please give us a call on 03304333888 > option 4 > option 4 > option 1 or alternatively raise a ticket with the technical support team.

Kind Regards,

Giacom - Service Desk

Root Cause

February 20, 3:24pm GMT

February 20, 3:24pm GMT

Good Afternoon,


After rerunning all the outstanding orders this morning and monitoring the M365 orders throughout the day, we can now confirm the issues have now resolved.


We will now close off the parent incident, if you do continue to see any issues with orders not populating within the M365 Admin center even though the orders are complete on cloud market, please give us a call on 03304333888 > option 4 > option 4 > option 1 or alternatively raise a ticket with the technical support team.



Kind Regards,


Giacom - Service Desk