Microsoft orders and scheduled actions issue

Incident
March 02, 1:43pm GMT

Microsoft orders and scheduled actions issue

Status: In progress
Start: March 02, 8:31am GMT
Affected Components:
Modern Workplace Microsoft Microsoft 365 Exchange Online Microsoft Teams Dynamics Power BI Perpetual Licencing
Update

March 02, 8:31am GMT

March 02, 8:31am GMT

We’re aware of an issue where some Microsoft 365 orders placed through our portal are not appearing as expected.

 

We’ve also noted that some scheduled changes from this weekend haven’t completed yet. We’ve got full visibility of these and we’re reviewing each one to make sure any outstanding actions are handled appropriately.

 

Our teams are actively working to resolve this and minimise any impact. We’ll continue to post updates here as soon as more information becomes available.

 

Thank you for your patience.

Update

March 02, 1:43pm GMT

March 02, 1:43pm GMT

We’ve resolved the issue preventing partners from placing orders in the Cloud Market portal.

 

We’re continuing to review scheduled changes that haven’t completed, along with any orders that were placed but didn’t generate an order ID. 

 

We have full visibility of these and are working through each item to ensure any outstanding actions are completed.

 

We’ll post further updates here as soon as more information becomes available.


Kind regards,

Giacom - Service Desk