Microsoft 365 Ordering issues

Incident
June 01, 2:54pm BST

Microsoft 365 Ordering issues

Status: In progress
Start: June 01, 10:37am BST
Affected Components:
Cloud Infrastructure Modern Workplace Microsoft Microsoft Azure Azure Microsoft 365 Exchange Online Azure Reserved Instances Microsoft Teams Azure Server Subscriptions Cloud Server Dynamics Power BI Perpetual Licencing
Update

June 01, 10:37am BST

June 01, 10:37am BST

Good morning,

We are aware of an issue with placing Microsoft orders this morning that we believe is currently related to an on-going Microsoft issue in their Partner Centre.

We are monitoring the issue and will let you know when we get further updates. Orders that show as failed will create a ticket with our support teams and we will review and re-run this when the issue is resolved.

If you are unsure if you're order is impacted, please contact our support team.

Kind regards,

Giacom - Service Desk

Update

June 01, 2:54pm BST

June 01, 2:54pm BST

Good Afternoon,

After further monitoring, we are now seeing new orders completing consistently.

We will are start reviewing all failed orders and complete them where possible and cancel the ones that cannot be completed, with a request to replace those orders as needed. 

If you have any further queries or questions in the meantime, please do not hesitate to reach out.

Kind regards,

Giacom - Service Desk