Orders for Microsoft 365 Business Standard not processing

Incident
August 26, 4:33pm BST

Orders for Microsoft 365 Business Standard not processing

Status: In progress
Start: August 26, 1:27pm BST
Affected Components:
Modern Workplace Platform Microsoft Cloud Cloud.Market Billing API Microsoft 365
Update

August 26, 1:27pm BST

August 26, 1:27pm BST

Good afternoon,

We're aware of an issue preventing partners from placing orders for Microsoft 365 Business Standard licences.

Our team is investigating this as a priority and we'll provide a further update as soon as we have more information.

We apologise for any inconvenience caused and appreciate your patience.

Kind regards,

Giacom Cloud - Service Desk

 

Update

August 26, 4:33pm BST

August 26, 4:33pm BST

Good afternoon,

 

Our Development Team has implemented a fix for the issue and is continuing to monitor the results.

 

Orders should now process successfully. If you're still experiencing any issues, please let us know and we'll investigate further.

 

Thank you for your patience while we worked to resolve this.

 

Kind regards,
Giacom - Service Desk